21 lines
488 B
Nix
21 lines
488 B
Nix
{
|
|
inputs = {
|
|
nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
|
|
flake-utils.url = "github:numtide/flake-utils";
|
|
};
|
|
|
|
outputs =
|
|
{ nixpkgs, flake-utils, ... }:
|
|
flake-utils.lib.eachDefaultSystem (
|
|
system:
|
|
let
|
|
pkgs = nixpkgs.legacyPackages.${system};
|
|
nativeBuildInputs = with pkgs; [
|
|
texlive.combined.scheme-full
|
|
];
|
|
in
|
|
{
|
|
devShells.default = pkgs.mkShell { inherit nativeBuildInputs; };
|
|
}
|
|
);
|
|
}
|